Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M22-05

Το παρακάτω πρόγραμμα συγχωνεύει τα ταξινομημένα στοιχεία δύο πινάκων Α, Β σε έναν πίνακα Γ.

Τι θα εμφανίσει αν στον πίνακα Α εισάγουμε διαδοχικά τα στοιχεία 2, 6, 9 (δηλαδή Ν=3) και στον πίνακα Β τα 3, 4, 8, 11, 19 (δηλαδή Μ=5);

 

ΠΡΟΓΡΑΜΜΑ Συγχώνευση

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: Α[100], Β[100], Γ[200], I, J, K, N, M, Λ

ΑΡΧΗ

ΓΡΑΨΕ ‘Δώσε το πλήθος των στοιχείων που θα εισάγουμε στον πίνακα Α (< 100)’

ΔΙΑΒΑΣΕ N

ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ N

ΔΙΑΒΑΣΕ A[I]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘Δώσε το πλήθος των στοιχείων που θα εισάγουμε στον πίνακα B (< 100)’

ΔΙΑΒΑΣΕ M

ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ M

ΔΙΑΒΑΣΕ B[I]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

I <-- 1

J <-- 1

K <-- 1

ΌΣΟ I <= Ν ΚΑΙ J <= M ΕΠΑΝΑΛΑΒΕ

ΑΝ A[I] < Β[J] ΤΟΤΕ

Γ[Κ] <-- A[I]

K <-- K + 1

I <-- I + 1

ΑΛΛΙΩΣ

Γ[Κ] <-- Β[J]

K <-- K + 1

J <-- J + 1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΝ I > N ΤΟΤΕ

ΓΙΑ Λ ΑΠΟ Κ ΜΕΧΡΙ Ν+Μ

Γ[Λ] <-- Β[J]

J <-- J + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΛΛΙΩΣ

ΓΙΑ Λ ΑΠΟ Κ ΜΕΧΡΙ Ν+Μ

Γ[Λ] <-- A[I]

I <-- I + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΑΝ

ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ Ν+Μ

ΓΡΑΨΕ Γ[Λ]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Χωρίς ήχο

Dim lights

 

sideBar



You are here: Mathman