Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M21-01

Δίνεται ο παρακάτω αλγόριθμος:

 

ΓΙΑ i ΑΠΟ ... ΜΕΧΡΙ n

ΓΙΑ j ΑΠΟ ... ΜΕΧΡΙ ... ΜΕ_ΒΗΜΑ ...

ΑΝ Α[j] ... Α[j-1] ΤΟΤΕ

temp <-- A[j]

Α[   ] <-- Α[    ]

Α[    ] <-- temp

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 

Να γράψετε στο τετράδιό σας τον παραπάνω αλγόριθμο κατάλληλα συμπληρωμένο, έτσι ώστε να υλοποιεί την ταξινόμηση της φυσαλίδας με αύξουσα σειρά.

(ΕΠΑΝ ΕΣΠ 2008)

 

Χωρίς ήχο

Dim lights

 

 

sideBar



You are here: Mathman