Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M20-10

Να περιγράψετε τον αλγόριθμο ταξινόμησης ευθείας ανταλλαγής με ψευδοκώδικα

Αλγόριθμος Φυσαλίδα

Δεδομένα // table, n //

Για i από 2 μέχρι n

Για j από n μέχρι i με_βήμα -1

Αν table[j-1] > table[j] τότε

temp <-- table[j-1]

table[j-1] <-- table[j]

table[j] <-- temp

Τέλος_αν

Τέλος_επανάληψης

Τέλος_επανάληψης

Αποτελέσματα // table //

Τέλος Φυσαλίδα

sideBar



You are here: Mathman