Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M27-03

Δίνεται το παρακάτω πρόγραμμα σε γλώσσα:

 

ΠΡΟΓΡΑΜΜΑ Α

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: x, n, m, pow, z

ΑΡΧΗ

ΔΙΑΒΑΣΕ x, n

m <-- n

pow <-- 1

z <-- x

ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ

ΟΣΟ ( m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ

m <-- m DIV 2

z <-- z * z

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

m <-- m-1

ΓΡΑΨΕ pow

pow <-- pow*z

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ pow

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

 

α. Να κατασκευάσετε το ισοδύναμο διάγραμμα ροής του προγράμματος Α.

β. Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί:

x = 2,     n = 3.

(ΠΑΝΕΛΛΑΔΙΚΕΣ 2008)

 

Χωρίς ήχο

ερώτημα α

Dim lights

 

ερώτημα β

Dim lights

sideBar



You are here: MAIN PAGE