Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M07-06

Να γραφεί αλγόριθμος ο οποίος θα δέχεται ως είσοδο τρεις αριθμούς, θα υπολογίζει και εμφανίζει το μέγιστο αυτών.

Dim lights

 

Σύμφωνα με τα παραπάνω προκύπτει ότι μία δεύτερη λύση για το μέγιστο 2 δύο αριθμών ( E 25 ) θα ήταν η ακόλουθη :

 

...

max <-- α

Αν β > max τότε

max <-- β

Τέλος_αν

...

 

Αλλά για το μέγιστο των 3 αριθμών, σωστός είναι και ο παρακάτω αλγόριθμος :

...

Αν α > β τότε

max <-- α

αλλιώς

max <-- β

Τέλος_αν

Αν γ > max τότε

max <-- γ

Τέλος_αν

...

 

Υπάρχουν άλλες 3 λύσεις για το μέγιστο 3 αριθμών, η παρουσίαση των οποίων όμως θα γίνει αργότερα.

Γενικότερα συμβουλεύουμε να χρησιμοποιείτε τον αλγόριθμο της παραπάνω video-παρουσίασης για λόγους που θα καταλάβετε προχωρώντας στην ύλη του μαθήματος.

 

Θα λέγαμε πως το μέγιστο 3 αριθμών είναι μια πολύ σημαντική άσκηση στα προβλήματα

Βελτιστοποίησης

optim

 

 

Κάνετε αντιγραφή κι επικόλληση του κώδικα στον online compiler της Python

https://www.tutorialspoint.com/execute_python_online.php

 

# Python program to find the largest number among the three input numbers

a = int(input("Enter first number: "))
b = int(input("Enter second number: "))
c = int(input("Enter third number: "))

max=a

if (b >max) :
max = b
if (c >max) :
max = c

print("maximum value between",a,",",b,"and",c,"is",max)

 

sideBar



You are here: MAIN PAGE