Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M20-01

Δίνεται η παρακάτω ακολουθία εντολών που στοχεύει στην υλοποίηση ενός αλγορίθμου αναζήτησης κάποιου στοιχείου Χ σε πίνακα Π με Ν στοιχεία:

Αλγόριθμος Αναζήτηση

Δεδομένα //Π,Ν,Χ//

flag <-- ψευδής

Ι <-- 1

Όσο Ι ≤ Ν και flag=ψευδής επανάλαβε

Αν Π[Ι]=Χ τότε

flag <--αληθής

Τέλος_αν

Τέλος_επανάληψης

Αποτελέσματα //flag//

Τέλος Αναζήτηση

 

1. Ποιο αλγοριθμικό κριτήριο δεν ικανοποιεί η παραπάνω ακολουθία εντολών;

Να αιτιολογήσετε την απάντησή σας.

2. Να διορθώσετε την παραπάνω ακολουθία εντολών έτσι ώστε να υλοποιεί σωστά την αναζήτηση.

(ΕΠΑΝ 2007)

Dim lights

 

sideBar



You are here: Mathman