Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M19-08

Να περιγράψετε τον αλγόριθμο σειριακής αναζήτησης με ψευδοκώδικα.

Αλγόριθμος Sequential_Search

Δεδομένα // table, key, n //

done <-- ψευδής

position <-- 0

i <-- 1

Όσο done = ψευδής και i <= n επανάλαβε

Αν table[i] = key τότε

done <-- αληθής

position <-- i

αλλιώς

i <-- i + 1

Τέλος_αν

Τέλος_επανάληψης

Αποτελέσματα // done, position //

Τέλος Sequential_Search

 

 

sideBar



You are here: Mathman