Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M18-04

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει έναν πίνακα 50x100, θα υπολογίζει και θα εμφανίζει το ποσοστό των μηδενικών στοιχείων.

 

Αλγόριθμος Άσκηση

πλήθος <-- 0

Για i από μέχρι 50

Για j από 1  μέχρι 100

Διάβασε Π[i, j]

Αν Π[i, j] =0 τότε

πλήθος <-- πλήθος + 1

Τέλος_αν

Τέλος_επανάληψης

Τέλος_επανάληψης

ποσοστό <-- πλήθος/(50*100)*100

Εμφάνισε ποσοστό

Τέλος Άσκηση

sideBar



You are here: Mathman