Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M17-10

Δίνεται ο μονοδιάστατος πίνακας C με έξι στοιχεία που έχουν αντίστοιχα τις παρακάτω τιμές:

2, 5, 15, -1, 32, 14

και το παρακάτω τμήμα αλγορίθμου:

 

min <-- 100

max <-- -100

Για i από 1 μέχρι 6 με_βήμα 2

A <-- C[i]

B <-- C[i+1]

Αν A < B τότε

Lmin <-- A

Lmax <-- B

αλλιώς

Lmin <-- B

Lmax <-- A

Τέλος_αν

Αν Lmin < min τότε

min <-- Lmin

Τέλος_αν

Αν Lmax > max τότε

max <-- Lmax

Τέλος_αν

Εκτύπωσε Α, Β, Lmin, Lmax, min, max

Τέλος_επανάληψης

D <-- max*min

Εκτύπωσε D

 

Να εκτελέσετε το παραπάνω τμήμα αλγορίθμου και να γράψετε στο τετράδιό σας:

α.   Τις τιμές των μεταβλητών A, B, Lmin, Lmax, min και max, όπως και αυτές που εκτυπώνονται σε κάθε επανάληψη.

β.   Την τιμή της μεταβλητής D που εκτυπώνεται.

(Πανελλήνιες Εξετάσεις 2004)

Dim lights

 

sideBar



You are here: Mathman