Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M17-09

Σε μία κατασκήνωση υπάρχουν 300 παιδιά και καθένα από αυτά έχει μοναδικό αριθμό από το 1 έως και το 300 που του αντιστοιχεί. Για κάθε παιδί είναι γνωστή η ηλικία του. Να χρησιμοποιηθεί η δομή του πίνακα για να αποθηκεύονται οι ηλικίες των παιδιών και να βρεθεί ο κατάλληλος αλγόριθμος υπολογισμού του μικρότερου και του μεγαλύτερου σε ηλικία παιδιού και να εκτυπώνεται τόσο η ηλικία όσο και ο κωδικός του μικρότερου και του μεγαλύτερου παιδιού. (ΔΤ1_3)

(Θεωρούμε ότι περισσότερα από ένα παιδιά θα έχουν την μικρότερη και τη μεγαλύτερη ηλικία)

 

Αλγόριθμος Άσκηση

Για i από 1 μέχρι 300

Διάβασε ΗΛ[i]

Τέλος_επανάληψης

min <-- HΛ[1]

max <-- HΛ[1]

Για i από 2 μέχρι 300

Αν HΛ[i] < min τότε

min <-- HΛ[i]

Τέλος_αν

Αν HΛ[i] > max τότε

max <-- HΛ[i]

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε min, max

Για i από 1 μέχρι 300

Αν HΛ[i] = min τότε

Εμφάνισε i

Τέλος_αν

Αν HΛ[i] = max τότε

Εμφάνισε i

Τέλος_αν

Τέλος_επανάληψης

Τέλος Άσκηση

sideBar



You are here: Mathman