Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M17-08

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει τις θερμοκρασίες 30 ημερών, θα τις καταχωρεί σε έναν πίνακα, θα υπολογίζει και θα εμφανίζει την μέγιστη θερμοκρασία, καθώς και την ημέρα που παρατηρήθηκε.

 

Αλγόριθμος Άσκηση

Για i από 1 μέχρι 30

Διάβασε Θ[i]

Τέλος_επανάληψης

max <-- Θ[1]

θmax <-- 1

Για i από 2 μέχρι 30

Αν Θ[i] > max τότε

max <-- Θ[i]

θmax <-- i

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε max, θmax

Τέλος Άσκηση

 

Αλγόριθμος Άσκηση

Διάβασε Θ[1]

max <-- Θ[1]

θmax <-- 1

Για από μέχρι 30

Διάβασε Θ[i]

Αν Θ[i] > max τότε

max <-- Θ[i]

θmax <-- i

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε max, θmax

Τέλος Άσκηση

sideBar



You are here: Mathman