Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M16-27

Υπολογισμός ελάχιστου στοιχείου μονοδιάστατου πίνακα (ομοίως για μέγιστο)

 

Αλγόριθμος Ελάχιστο_ Πίνακα

Δεδομένα // Α, n //

min <-- Α[1]

Για i από 2 μέχρι n

Αν Α[i] < min τότε

min <-- Α[i]

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε min

Τέλος Ελάχιστο_Πίνακα

 

Υπολογισμός ελάχιστου στοιχείου μονοδιάστατου πίνακα (ομοίως για μέγιστο) και μία θέση ελαχίστου (μεγίστου)

Αλγόριθμος Ελάχιστο_ Πίνακα

Δεδομένα // Α, n //

min <-- Α[1]

θmin <-- 1

Για i από 2 μέχρι n

Αν Α[i] < min τότε

min <-- Α[i]

θmin <-- i

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε min, θmin

Τέλος Ελάχιστο_Πίνακα

 

Υπολογισμός ελάχιστου στοιχείου μονοδιάστατου πίνακα (ομοίως για μέγιστο) και όλες τις θέσεις ελαχίστου (μεγίστου)

Αλγόριθμος Ελάχιστο_ Πίνακα

Δεδομένα // Α, n //

min <-- Α[1]

Για i από 2 μέχρι n

Αν Α[i] < min τότε

min <-- Α[i]

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε min

Για i από 1 μέχρι n

Αν Α[i] = min τότε

Εμφάνισε i

Τέλος_αν

Τέλος_επανάληψης

Τέλος Ελάχιστο_Πίνακα

sideBar



You are here: Mathman