Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M16-25

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει έναν πίνακα 50 θέσεων και θα υπολογίζει τον μέσο όρο των στοιχείων του.

Αλγόριθμος Άσκηση

Για i από 1 μέχρι 50

Διάβασε Α[ i ]

Τέλος_επανάληψης

s <-- 0

Για i από 1 μέχρι 50

s <-- s + A[ i ]

Τέλος_επανάληψης

MO <-- s/50

Εμφάνισε MO

Τέλος Άσκηση

 

Στην παρακάτω λύση παρατηρούμε ότι η επεξεργασία (υπολογισμός αθροίσματος) μπορεί να γίνει ταυτόχρονα με την είσοδο των δεδομένων.

Αλγόριθμος Άσκηση

s <-- 0

Για i από 1 μέχρι 50

Διάβασε Α[ i ]

s <-- s + A[ i ]

Τέλος_επανάληψης

MO <-- s/50

Εμφάνισε MO

Τέλος Άσκηση

 

 

sideBar



You are here: Mathman