Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M16-22

Εισαγωγή Δεδομένων σε Μονοδιάστατο Πίνακα


Ο πιο συνηθισμένος τρόπος εισαγωγής δεδομένων σε Μονοδιάστατο Πίνακα Α, n θέσεων είναι με δομή επανάληψης Για

(αφού το μέγεθος του πίνακα είναι σταθερό, έχουμε γνωστό πλήθος επαναλήψεων)

Δεδομένα // n //

Για i από 1 μέχρι n

Διάβασε Α[i]

Τέλος_επανάληψης

 

Σε αλγορίθμους θεωρίας και σε λίγες μόνο ασκήσεις, χάριν συντομίας το παραπάνω τμήμα μπορεί να αντικατασταθεί από την εντολή

Δεδομένα // A, n //

 

Στις περισσότερες ασκήσεις των Πανελλαδικών Εξετάσεων όμως, το μέγεθος του πίνακα θα δίνεται (πχ n=100) και πάντα θα πρέπει να γράφουμε

Για i από 1 μέχρι 100

Διάβασε Α[i]

Τέλος_επανάληψης


Εννοείται όμως ότι μπορούμε να εισάγουμε τιμή για κάποιο μεμονωμένο στοιχείο του πίνακα χωρίς δομή επανάληψης Για.

Παραδείγματα:

Διάβασε Α[2]

Α[4] <-- 11

 

Μην ξεχνάμε ότι όταν γράφουμε ΠΡΟΓΡΑΜΜΑ, το μέγεθος του πίνακα δηλώνεται ΜΟΝΟ στο τμήμα δήλωσης μεταβλητών και σταθερών, άρα κατά τον προγραμματισμό και όχι κατά την εκτέλεση.

Παράδειγμα:

ΠΡΟΓΡΑΜΜΑ 'Ασκηση

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: Α[30], x

………

 

Σε καμία περίπτωση το μέγεθος του πίνακα δεν καθορίζεται (εισάγεται) από τον χρήστη κατά την εκτέλεση, δηλαδή δεν γράφουμε ποτέ στο πρόγραμμα:

Διάβασε n

Για i από 1 μέχρι n

Διάβασε Α[i]

Τέλος_επανάληψης

Η εντολή Διάβασε n μπορεί να χρειαστεί (με έλεγχο δεδομένων) σε πιο προχωρημένες ασκήσεις, όταν θα ζητηθεί από τον χρήστη να καθορίσει το πόσες από τις διαθέσιμες θέσεις του πίνακα θα χρησιμοποιηθούν.


Στην περίπτωση που θέλουμε να χρησιμοποιήσουμε ένα συμβολικό χαρακτήρα για το μέγεθος του πίνακα, τότε πρέπει να τον δηλώσουμε στο τμήμα ΣΤΑΘΕΡΩΝ.

Παράδειγμα:

ΠΡΟΓΡΑΜΜΑ Άσκηση

ΣΤΑΘΕΡΕΣ

n = 30

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: Α[n], x

..........

 

sideBar



You are here: Mathman