Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M15-02

Δίνεται το παρακάτω τμήμα αλγόριθμου:

α <-- 5

β <-- 3

Για Χ από 2 μέχρι 7 με_βήμα 4

Όσο α < =10 επανάλαβε

β <-- β + α

α <-- α + 4

Τέλος_επανάληψης

Εμφάνισε α, β

α <-- 4

Τέλος_επανάληψης

Εμφάνισε α

 

Να γράψετε στο τετράδιό σας τις τιμές που εμφανίζονται κατά την εκτέλεση του παραπάνω τμήματος αλγόριθμου.

(ΕΠΑΝ ΕΣΠ 2007)

Dim lights

Η ιδιαιτερότητα σ' αυτή τη διπλή επανάληψη είναι ότι η μεταβλητή α, η οποία καθορίζει τις εσωτερικές επαναλήψεις, παίρνει αρχική τιμή έξω από τη διπλή επανάληψη, και η τιμή της επαναφέρεται στο 4 κάθε φορά πριν ξεκινήσει μία νέα εξωτερική επανάληψη.

sideBar



You are here: Mathman