Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M15-01

Το παρακάτω τμήμα προγράμματος να μετατραπεί σε ισοδύναμο, χρησιμοποιώντας αποκλειστικά τη δομή επανάληψης ΟΣΟ… ΕΠΑΝΑΛΑΒΕ.

S <-- 0

ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 5

ΓΙΑ L ΑΠΟ 1 ΜΕΧΡΙ 7

S <-- S + 1

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ S

 

(ΕΠΑΝ ΕΣΠ 2005)

Dim lights

Μπορούμε να παρατηρήσουμε ότι η μεταβλητή S έχει το ρόλο μετρητή, ή εναλλακτικά μπορούμε να πούμε το ρόλο αθροιστή μονάδων.

Η αρχική της τιμή είναι 0, και αυξάνεται κατά 1 σε κάθε επανάληψη της διπλής Για, που εκτελείται.

Επειδή οι μεταβλητές Κ και L ξεκινούν από 1 και φτάνουν μέχρι 5 και 7 αντίστοιχα, θα έχουμε στο σύνολο 5x7=35 επαναλήψεις.

Δηλαδή η μεταβλητή S θα πάρει τελικά την τιμή 35 η οποία και θα εμφανιστεί μετά το τέλος των επαναλήψεων.

sideBar



You are here: Mathman