Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M14-06

Δίνεται το παρακάτω τμήμα αλγορίθμου όπου οι μεταβλητές Κ, L, M είναι ακέραιες:

 

K <-- 35

L <-- 17

M <-- 0

OΣΟ  L > 0  ΕΠΑΝΑΛΑΒΕ

ΑΝ  L MOD 2=1 TOTE

M <-- M + K

ΤΕΛΟΣ_ΑΝ

Κ <-- Κ*2

L <-- L DIV 2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΕΜΦΑΝΙΣΕ Μ

 

α) Να συμπληρώσετε τον πίνακα παρακολούθησης τιμών

β) Για ποια τιμή της μεταβλητής L τερματίζει ο αλγόριθμος;

γ) Ποια είναι η τελική τιμή της μεταβλητής Μ;    (ΕΣΠ 2005)

Dim lights

 

sideBar



You are here: Mathman