Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M14-01

Να γράψετε στο τετράδιο σας τις τιμές των μεταβλητών Ν, Μ και Β, όπως αυτές τυπώνονται σε κάθε επανάληψη, και την τιμή της μεταβλητής Χ που τυπώνεται μετά το τέλος της επανάληψης, κατά την εκτέλεση του παρακάτω αλγόριθμου.

 

Αλγόριθμος Αριθμοί

Α <-- 1

Β <-- 1

Ν <-- 0

Μ <-- 2

Όσο Β < 6 επανάλαβε

Χ <-- Α + Β

Αν Χ MOD 2 = 0 τότε

N <-- N + 1

αλλιώς

M <-- M + 1

Τέλος_αν

A <-- B

B <-- X

Εμφάνισε Ν, Μ, Β

Τέλος_επανάληψης

Εμφάνισε Χ

Τέλος Αριθμοί

(Πανελλήνιες Εξετάσεις 2003)

Dim lights

 

sideBar



You are here: Mathman