Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M13-19

Τι γνωρίζετε για τις εντολές Δεδομένα // … // και Αποτελέσματα // … // ;

Τα Δεδομένα εισόδου (αν υπάρχουν) περιγράφονται στη δεύτερη γραμμή του αλγορίθμου εντός των συμβόλων // ... //.

Αντίστοιχα τα Αποτελέσματα εξόδου δίνονται στην προτελευταία γραμμή του αλγορίθμου εντός των συμβόλων // ... //.

Αλγόριθμος  Παράδειγμα_12

Δεδομένα // Μ1, Μ2 //

P <-- 0

Όσο Μ2 > 0  επανάλαβε

Αν M2 mod 2 = 1  τότε

P <-- P + M1

Τέλος_αν

M1 <-- M1*2

M2 <-- M2 div 2

Τέλος_επανάληψης

Αποτελέσματα // P //

Τέλος  Παράδειγμα_12

Οι εντολές Δεδομένα // … // και Αποτελέσματα // … // μπορούν να αντικαταστήσουν τις εντολές εισόδου και εξόδου ΜΟΝΟ στη ψευδογλώσσα και στην περίπτωση που ο αλγόριθμος δεν χρειάζεται τιμές για τις μεταβλητές εισόδου από το πληκτρολόγιο ή να εμφανίσει/εκτυπώσει τις τιμές των μεταβλητών στην μονάδα εξόδου (οθόνη ή εκτυπωτής).

Για παράδειγμα, είσοδος σε αλγόριθμο μπορεί να αποτελέσει η έξοδος ενός άλλου αλγόριθμου (σε μια συναλλαγή με το ΑΤΜ της τράπεζας, δίνουμε σαν είσοδο από το πληκτρολόγιο μόνο το PIN της κάρτας, και όχι το διαθέσιμο υπόλοιπο που έχουμε).

Καλό είναι να γνωρίζουμε την λειτουργία τους όταν μας δίνονται σε αλγόριθμο (σπάνια), αλλά να μην τις χρησιμοποιούμε όταν εμείς γράφουμε αλγόριθμο, επειδή τα περισσότερα προβλήματα ζητούν είσοδο από το πληκτρολόγιο και έξοδο στην οθόνη.

 

sideBar



You are here: Mathman