Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M13-01

Δίνεται το παρακάτω τμήμα αλγορίθμου.

Χ <-- 1

Όσο Χ < 5 επανάλαβε

Α <-- Χ + 2

Β <-- 3*Α – 4

C <-- B – A + 4

Αν Α > Β τότε

Αν Α > C τότε

MAX <-- A

αλλιώς

MAX <-- C

Τέλος_αν

αλλιώς

Αν Β > C τότε

MAX <-- Β

αλλιώς

MAX <-- C

Τέλος_αν

Τέλος_αν

Εμφάνισε Χ, Α, Β, C, MAX

X <-- X + 2

Τέλος_επανάληψης

Ποιες είναι οι τιμές των μεταβλητών Χ, Α, Β, C, MAX που θα εμφανιστούν κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου; (Πανελλήνιες Εξετάσεις 2001)

Dim lights

 

sideBar



You are here: Mathman