Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M12-05

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει τη μέση ημερήσια θερμοκρασία για κάθε ημέρα ενός μήνα 30 ημερών, θα υπολογίζει και θα εμφανίζει την ελάχιστη και την μέγιστη από αυτές τις θερμοκρασίες.

 

Για την παραπάνω εκφώνηση, προτείνεται η παρακάτω αλγοριθμική λύση.

Είναι σωστή ή λάθος; Δικαιολογείστε την απάντηση σας.

 

Αλγόριθμος  Άσκηση

Διάβασε θ

max <-- θ

min <-- θ

Για i από 2 μέχρι 30

Διάβασε θ

Αν θ < min τότε

min <-- θ

αλλιώς_αν θ > max τότε

max <-- θ

Τέλος_αν

Τέλος_επανάληψης

Εμφάνισε max, min

Τέλος  Άσκηση

Dim lights

Είναι σωστή (;) η αντίστοιχη αλγοριθμική λύση με αρχικοποίηση

max <-- -100

min <-- 100

Για i από 1 μέχρι 30

Διάβασε θ

Αν θ < min τότε

min <-- θ

αλλιώς_αν θ > max τότε

max <-- θ

Τέλος_αν

Τέλος_επανάληψης

;;;;;

 

sideBar



You are here: Mathman