Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M12-02

Να εκτελέσετε το παρακάτω τμήμα αλγορίθμου, για Κ = 24 και L = 40.

Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών X, Y καθώς και αυτές που τυπώνονται με την εντολή Εμφάνισε X, Y (τόσο μέσα στη δομή επανάληψης όσο και στο τέλος του αλγορίθμου).

(Πανελλήνιες Εξετάσεις 2002)

 

X <-- K

Y <-- L

Αν X < Y τότε

TEMP <-- X

X <-- Y

Y <-- TEMP

Τέλος_αν

Όσο Υ < > 0 επανάλαβε

TEMP <-- Y

Y <-- X MOD Y

X <-- TEMP

Εμφάνισε Χ, Υ

Τέλος_επανάληψης

Υ <-- (Κ * L) DIV X

Εμφάνισε Χ, Υ

Dim lights

sideBar



You are here: Mathman