Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M07-03

Τι θα εμφανίσει ο ακόλουθος αλγόριθμος, αν σαν είσοδος δοθούν οι τιμές 5, 4 και 6 αντίστοιχα;

Αλγόριθμος  K

Διάβασε α, β, γ

Αν α mod 2 = 1 ή β >= 7 τότε

γ <-- γ + 2

Αν γ < β τότε

α <-- β+1

αλλιώς

β <-- 2*α+3

Τέλος_αν

Τέλος_αν

α <-- β mod γ - 1

γ <-- β div α - 2

Εμφάνισε α, β, γ

Τέλος  K

Dim lights

Στο 1:48 ακούγεται " 6 < 4 Ψευδής ", ενώ το σωστό είναι " 8 < 4 Ψευδής ". Η ροή της λύσης δεν επηρεάζεται και τα αποτελέσματα είναι σωστά (όπως φαίνονται).

sideBar



You are here: Mathman