Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M06-16

Πως συντάσσεται η εμφωλευμένη δομή επιλογής;

 

Οι εμφωλευμένες δομές μπορούν να προκύψουν με συνδυασμό όσων και όποιων δομών επιλογής θέλουμε ή χρειάζονται στη λύση ενός προβλήματος.

Αρκεί η εσωτερική δομή επιλογής να βρίσκεται εξ’ ολοκλήρου μέσα στην εξωτερική δομή επιλογής.

 

Ενδεικτικά παρατίθεται το ακόλουθο σχήμα εμφωλευμένων δομών επιλογής:

Αν < συνθήκη_1 > τότε

Αν < συνθήκη_2 >  τότε

< εντολές_2 >

Τέλος_αν

αλλιώς_αν < συνθήκη_3 > τότε

Αν < συνθήκη_4 > τότε

< εντολές_34 >

αλλιώς

< εντολές_3_4 >

Τέλος_αν

αλλιώς

< εντολές_5 >

Τέλος_αν

 


 

sideBar



You are here: Mathman