Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M06-11

Πολλαπλή επιλογή με ή χωρίς  το  αλλιώς (έλεγχος δεδομένων)

 

Δίνεται η παρακάτω άσκηση του σχολικού και η προτεινόμενη λύση με πολλαπλή δομή επιλογής.

Σε ένα φυτώριο υπάρχουν 3 είδη δένδρων που θα δοθούν για δενδροφύτευση. Το 1ο είδος δένδρου θα δοθεί στην περιοχή της Μακεδονίας, το 2ο στην περιοχή της Θράκης και το 3ο είδος στην περιοχή της Πελοποννήσου. Να γραφεί ένας αλγόριθμος που θα διαβάζει τον αριθμό του είδους του δένδρου και θα εκτυπώνει την περιοχή στην οποία θα γίνει η δενδροφύτευση. (ΔΤ9_2)

 

Αλγόριθμος   Άσκηση

Εμφάνισε “Δώσε είδος δέντρου: ”

Διάβασε Δ

Αν  Δ = 1  τότε

Εμφάνισε “ Μακεδονία ”

αλλιώς_αν  Δ = 2  τότε

Εμφάνισε “ Θράκη ”

αλλιώς_αν  Δ = 3  τότε

Εμφάνισε “ Πελοπόννησος ”

αλλιώς

Εμφάνισε “ Λάθος Δεδομένα ”

Τέλος_αν

Τέλος  Άσκηση

 

 

Διάβασε Δ

Αν  Δ = 1  τότε

Εμφάνισε “ Μακεδονία ”

αλλιώς_αν  Δ = 2  τότε

Εμφάνισε “ Θράκη ”

αλλιώς_αν  Δ = 3  τότε

Εμφάνισε “ Πελοπόννησος ”

Τέλος_αν

Διάβασε Δ

Αν  Δ = 1  τότε

Εμφάνισε “ Μακεδονία ”

αλλιώς_αν  Δ = 2  τότε

Εμφάνισε “ Θράκη ”

αλλιώς

Εμφάνισε “ Πελοπόννησος ”

Τέλος_αν

 

 

Να διερευνήσετε τι κάνουν κατά την εκτέλεσή τους τα άλλα δύο τμήματα πολλαπλής Αν και υπό ποιες προϋποθέσεις  είναι σωστά.

Τι συμπεράσματα προκύπτουν για τη δομή επιλογής γενικότερα, σχετικά με το αν υπάρχει ή όχι η περίπτωση αλλιώς;

Dim lights

Μετά την παρουσίαση, στη σελίδα 51 (Μ 18) του βιβλίου σημειώσεων, συμπληρώνουμε τα κενά:

το πολύ μία

Ακριβώς μία

Ίσως καμία

 

sideBar



You are here: Mathman