Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M04-20

Πως συντάσσεται η πολλαπλή δομή επιλογής;

 

Αν < συνθήκη_1 > τότε

< εντολές_1 >

αλλιώς_αν < συνθήκη_2 > τότε

< εντολές_2 >

αλλιώς

< εντολές_3 >

Τέλος_αν

Εκτελείται μόνο μία από τις ομάδες εντολών.

Όταν η < συνθήκη_1 >  είναι Αληθής, εκτελούνται οι < εντολές_1 > και ο αλγόριθμος συνεχίζει με την εντολή που ακολουθεί το Τέλος_αν .

Όταν είναι Ψευδής, ελέγχεται η < συνθήκη_2 >.

Όταν αυτή είναι Αληθής, εκτελούνται οι < εντολές_2 > και ο αλγόριθμος συνεχίζει με την εντολή που ακολουθεί το Τέλος_αν.

Όταν και αυτή είναι Ψευδής, εκτελούνται οι < εντολές_3 > που βρίσκονται στο αλλιώς και ο αλγόριθμος συνεχίζει με την εντολή που ακολουθεί το Τέλος_αν.

 

 

 

 

sideBar



You are here: Mathman