Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EK51

Δίνεται το παρακάτω τμήμα αλγορίθμου

ΑΝ X <= 50 TOTE

Κόστος <-- X * 580

ΑΛΛΙΩΣ_ΑΝ X > 50 ΚΑΙ X <= 100 ΤΟΤΕ

Κόστος <-- X * 520

ΑΛΛΙΩΣ_ΑΝ X > 100 ΚΑΙ X <= 200 ΤΟΤΕ

Κόστος <-- X * 470

ΑΛΛΙΩΣ

Κόστος <-- X * 440

ΤΕΛΟΣ_ΑΝ

 

Στο παραπάνω τμήμα αλγορίθμου, για το οποίο θεωρούμε ότι η ποσότητα X είναι θετικός αριθμός, περιλαμβάνονται περιττοί έλεγχοι.

Να το ξαναγράψετε παραλείποντας τους περιττούς ελέγχους. (ΕΠΑΝ 2006)

 

Λύση

(μαρκάρετε το κείμενο)

 

ΑΝ X <= 50 TOTE

Κόστος <-- X * 580

ΑΛΛΙΩΣ_ΑΝ X <= 100 ΤΟΤΕ

Κόστος <-- X * 520

ΑΛΛΙΩΣ_ΑΝ X <= 200 ΤΟΤΕ

Κόστος <-- X * 470

ΑΛΛΙΩΣ

Κόστος <-- X * 440

ΤΕΛΟΣ_ΑΝ

sideBar



You are here: Mathman