Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EK107

Δίνεται ο παρακάτω αλγόριθμος:

 

Αλγόριθμος Αριθμοί_ ΜΕΡΣΕΝ

Διάβασε Α

Β <-- 4

C <-- 2

Aρχή_επανάληψης

Β <-- (Β^2) – 2

Εμφάνισε Β

C <-- C + 1

Μέχρις_ότου C > (A – 1)

D <-- (2^A) – 1

E <-- B MOD D

Εμφάνισε D

Αν E = 0 τότε

F <-- (2^(C – 1)) * D

Εμφάνισε "Τέλειος αριθμός:", F

G <-- 0

Όσο F > 0 επανάλαβε

G <-- G + 1

F <-- F DIV 10

Τέλος_επανάληψης

Εμφάνισε G

Τέλος_αν

Τέλος Αριθμοί_ΜΕΡΣΕΝ

 

Να γράψετε στο τετράδιό σας τις τιμές που τυπώνει ο παραπάνω αλγόριθμος, αν του δώσουμε τιμές εισόδου:

α. 3

β. 4    (ΕΠΑΝ 2004)

α.

Dim lights

β.

Dim lights

sideBar



You are here: Mathman