Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EK167

Δίνεται ο πίνακας table:

1

7

11

20

35

78

99

Ο οποίος είναι ταξινομημένος με αύξουσα διάταξη.

Αν αναζητούμε στον πίνακα αυτό π.χ. τον αριθμό 15, ποιο είναι το ελάχιστο πλήθος επαναλήψεων που απαιτείται ώστε να απαντήσουμε ότι δεν υπάρχει στον πίνακα. Περιγράψτε τη σκέψη σας.

 

Να συμπληρώσετε τις εντολές που λείπουν από τον αλγόριθμο σειριακής αναζήτησης, ώστε να λειτουργεί βέλτιστα σε ταξινομημένο πίνακα αποφεύγοντας τις περιττές επαναλήψεις, κατά την αναζήτηση κάποιου στοιχείου.

 

Όσο (done = ψευδής) και (i <= Ν) επανάλαβε

Αν (table[i] = key) τότε

done <-- αληθής

____________________________

____________

Αλλιώς

i <-- i + 1

Τέλος_αν

Τέλος_επανάληψης

Σχετικό θέμα : E 189

Dim lights

sideBar



You are here: Mathman