Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EE223

Σε μια δημοτική δανειστική βιβλιοθήκη υπάρχουν 158 μέλη που δανείζονται βιβλία.

Να γραφεί αλγόριθμος που:

Δ1. α. Για κάθε μέλος διαβάζει το επώνυμο και το φύλο του (Α=άνδρας, Γ=γυναίκα) και τα αποθηκεύει στους πίνακες ΜΕΛΗ και ΦΥΛΟ, αντίστοιχα. Να γίνεται έλεγχος εγκυρότητας εισαγωγής του φύλου.

β. Για κάθε μήνα ενός έτους διαβάζει το πλήθος των βιβλίων που δανείστηκε κάθε μέλος και το αποθηκεύει στον πίνακα δύο διαστάσεων ΒΙΒΛΙΑ.

Δ2. Για κάθε μέλος υπολογίζει το συνολικό αριθμό των βιβλίων που δανείστηκε στο έτος και το αποθηκεύει στον πίνακα SUM.

Δ3.  α. Υπολογίζει το συνολικό αριθμό των βιβλίων που δανείστηκαν οι άνδρες.

β. Υπολογίζει το συνολικό αριθμό των βιβλίων που δανείστηκαν οι γυναίκες.

γ. Εμφανίζει κατάλληλο μήνυμα που δείχνει αν οι άνδρες ή οι γυναίκες έχουν δανειστεί τα περισσότερα βιβλία. Σε περίπτωση ίσων συνολικών αριθμών βιβλίων να εμφανίζει το μήνυμα “ΙΣΟΣ ΑΡΙΘΜΟΣ ΒΙΒΛΙΩΝ”.

Δ4. Να διαβάζει ένα επώνυμο και χρησιμοποιώντας τη σειριακή αναζήτηση, σε περίπτωση που το επώνυμο είναι αποθηκευμένο στον πίνακα ΜΕΛΗ, να εμφανίζει το σύνολο των βιβλίων που δανείστηκε στη διάρκεια του έτους. Σε περίπτωση που το επώνυμο δεν είναι αποθηκευμένο στον πίνακα να εμφανίζει το μήνυμα “ΤΟ ΕΠΩΝΥΜΟ ΑΥΤΟ ΔΕΝ ΥΠΑΡΧΕΙ”.

Σημείωση: Δεν απαιτείται κανένας άλλος έλεγχος εγκυρότητας εισαγωγής. Δεν υπάρχει συνωνυμία επωνύμων.

(ΕΣΠ 2010)

 

 

 

 

Αλγόριθμος Ασκ

       Για i από 1 μέχρι 158

              Διάβασε ΜΕΛΗ[i]

              Αρχή_επανάληψης

                   Διάβασε ΦΥΛΟ[i]

              Μέχρις_ότου ΦΥΛΟ[i]  = "A" ή ΦΥΛΟ[i] = "Γ"

     Τέλος_επανάληψης

       Για i από 1 μέχρι 158

              Για j από 1 μέχρι 12

                   Διάβασε ΒΙΒΛΙΑ[i, j]

              Τέλος_επανάληψης

     Τέλος_επανάληψης

     Για i από 1 μέχρι 158

              Σ 0

          Για j από 1 μέχρι 12

                   Σ Σ + ΒΙΒΛΙΑ[i, j]

          Τέλος_επανάληψης

              SUM[i] Σ

     Τέλος_επανάληψης

       Σανδρών 0

       Σγυναικών 0

       Για i από 1 μέχρι 158

              Αν ΦΥΛΟ[i]  ="Aτότε 

                   Σανδρών Σανδρών + SUM[i]

              Αλλιώς

                   Σγυναικών Σγυναικών + SUM[i]

              Τέλος_αν

     Τέλος_επανάληψης

       Αν Σανδρών > Σγυναικών τότε

              Εμφάνισε "Οι άνδρες έχουν δανειστεί περισσότερα βιβλία"

       Αλλιώς_αν Σγυναικών > Σανδρών τότε 

              Εμφάνισε "Οι γυναίκες έχουν δανειστεί περισσότερα βιβλία"

       αλλιώς

              Εμφάνισε "ΙΣΟΣ ΑΡΙΘΜΟΣ ΒΙΒΛΙΩΝ"

       Τέλος_αν         

       Διάβασε key

       i 1

       pos 0

       done ψευδής

       Όσο i <= 158 και done = ψευδής επανάλαβε

              Αν ΜΕΛΗ[i] = key τότε

                   done αληθής

                   pos i

          Αλλιώς

                   i i + 1

              Τέλος_αν

     Τέλος_επανάληψης

     Αν done = αληθής τότε

              Εμφάνισε SUM[pos]

     Αλλιώς

              Εμφάνισε "ΤΟ ΕΠΩΝΥΜΟ ΑΥΤΟ ΔΕΝ ΥΠΑΡΧΕΙ"

     Τέλος_αν

Τέλος Ασκ

 

 

sideBar



You are here: Mathman