Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EE173

 

Σε ένα Δήμο υπάρχουν 4 σταθμοί μέτρησης ενός συγκεκριμένου ατμοσφαιρικού ρύπου. Η καταγραφή της τιμής του ρύπου γίνεται ανά ώρα και σε 24ωρη βάση. Οι αποδεκτές τιμές του ρύπου κυμαίνονται από 0 έως και 100. Να γραφεί αλγόριθμος, ο οποίος:

α. για κάθε σταθμό και για κάθε ώρα του 24ώρου διαβάζει την τιμή του ρύπου και την καταχωρίζει σε πίνακα διαστάσεων 4x24, ελέγχοντας την εγκυρότητα κάθε τιμής,                                                    

β. για κάθε ώρα του 24ώρου υπολογίζει και εμφανίζει τη μέση τιμή του ρύπου από τους 4 σταθμούς.

γ. για κάθε σταθμό βρίσκει και εμφανίζει τη μέγιστη και την ελάχιστη τιμή του ρύπου στο 24ωρο.

δ. βρίσκει και εμφανίζει τη μέγιστη τιμή του ρύπου στη διάρκεια του 24ώρου, καθώς και την ώρα και τον αριθμό του σταθμού που σημειώθηκε η τιμή αυτή. (Να θεωρήσετε ότι η τιμή αυτή είναι μοναδική στον πίνακα).

                                                                                                                        (ΕΠΑΝ ΕΣΠ 2008)

 

Αλγόριθμος Ασκ_

   Για i από 1 μέχρι 4

      Για j από 1 μέχρι 24

         Αρχή_επανάληψης

            Διάβασε Μ[i , j ]

         Μέχρις_ότου Μ[i , j ] >= 0 και Μ[i , j ]<= 100

      Τέλος_επανάληψης

   Τέλος_επανάληψης

   Για j από 1 μέχρι 24

      Σ ← 0

      Για i από 1 μέχρι 4

         Σ ← Σ + Μ[i, j]

      Τέλος_επανάληψης

      μο ← Σ / 4

      Εμφάνισε μο

   Τέλος_επανάληψης

   Για i από 1 μέχρι 4

      max ← Μ[i, 1]

      min ← Μ[i, 1]

      Για j από 1 μέχρι 24

         Αν Μ[i, j] > max τότε

            max ← Μ[i, j]

         Τέλος_αν

         Αν Μ[i, j] < min τότε

            min ← Μ[i, j]

         Τέλος_αν

      Τέλος_επανάληψης

      Εμφάνισε max, min

   Τέλος_επανάληψης

   max ← Μ[1, 1]

   σταθμός ← 1

   ώρα ← 1

   Για i από 1 μέχρι 4

      Για j από 1 μέχρι 24

         Αν Μ[i, j] > max τότε

            max ← Μ[i, j]

            σταθμός ← i

            ώρα ← j

         Τέλος_αν

      Τέλος_επανάληψης

   Τέλος_επανάληψης

   Εμφάνισε max, σταθμός, ώρα

Τέλος Ασκ_

sideBar



You are here: Mathman