Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EE171

Ε 171) Μία Νομαρχία διοργάνωσε το 2008 σεμινάριο εθελοντικής δασοπυρόσβεσης, το οποίο παρακολούθησαν 500 άτομα. Η Πυροσβεστική Υπηρεσία ζήτησε στοιχεία σχετικά με την ηλικία, το φύλο και το μορφωτικό επίπεδο εκπαίδευσης κάθε εθελοντή, προκειμένου να εξαγάγει στατιστικά στοιχεία. Να γραφεί αλγόριθμος, ο οποίος:

α. διαβάζει για κάθε άτομο:

•  το ονοματεπώνυμο,

•  το έτος γέννησης (χωρίς να απαιτείται έλεγχος εγκυρότητας),

•  το φύλο, με αποδεκτές τιμές το “Α” για τους άνδρες και το “Γ” για τις γυναίκες,

•  το μορφωτικό επίπεδο εκπαίδευσης, με αποδεκτές τιμές “Π”, “Δ” ή “Τ”, που αντιστοιχούν σε Πρωτοβάθμια, Δευτεροβάθμια ή Τριτοβάθμια Εκπαίδευση,

και τα καταχωρίζει σε κατάλληλους μονοδιάστατους πίνακες.                                                      

β. υπολογίζει και εμφανίζει το πλήθος των ατόμων με ηλικία μικρότερη των 30 ετών.                  
γ.
υπολογίζει και εμφανίζει το ποσοστό των γυναικών με επίπεδο Τριτοβάθμιας Εκπαίδευσης στο σύνολο των εθελοντριών.                                                                                                                                      δ. εμφανίζει τα ονόματα των ατόμων με τη μεγαλύτερη ηλικία.                                                              

                                                                                                                        (ΕΠΑΝ ΕΣΠ 2008)

 

Αλγόριθμος Ασκ_171

   Για i από 1 μέχρι 500

      Διάβασε ΟΝ[i], ΕΤΟΣ[i]

      Αρχή_επανάληψης

         Διάβασε Φ[i]

      Μέχρις_ότου Φ[i]  = "A" ή Φ[i] = "Γ"

      Αρχή_επανάληψης

         Διάβασε ΜΟΡΦ[i]

      Μέχρις_ότου ΜΟΡΦ[i]  = "Π" ή ΜΟΡΦ[i] = "Δ" ή ΜΟΡΦ[i] = "Τ"

   Τέλος_επανάληψης

   max 0

   π 0

   πγυν 0

   πγυνΤριτ 0

   Για i από 1 μέχρι 500

      Αν 2008 – ΕΤΟΣ[i]  < 30 τότε

         π π + 1

      Τέλος_αν

      Αν Φ[i] = "Γ" τότε

         πγυν πγυν + 1

        Αν ΜΟΡΦ[i] = "Τ" τότε

           πγυνΤριτ πγυνΤριτ + 1

        Τέλος_αν

      Τέλος_αν

      Αν 2008 – ΕΤΟΣ[i]  > max  τότε

         max 2008 – ΕΤΟΣ[i]

      Τέλος_αν

   Τέλος_επανάληψης

   Εμφάνισε π

   Αν πγυν <> 0 τότε

      ποσ πγυνΤριτ / πγυν *100

      Εμφάνισε ποσ

   Τέλος_αν

   Για i από 1 μέχρι 500

      Αν 2008 – ΕΤΟΣ[i]  = max  τότε

         Εμφάνισε ΟΝ[i]

      Τέλος_αν

   Τέλος_επανάληψης

Τέλος Ασκ_171

sideBar



You are here: Mathman