Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EE211

Να γραφεί αλγόριθμος ο οποίος:

Α) θα διαβάζει ένα πίνακα Α 100 θέσεων με τα αποτελέσματα ρίψης κέρματος (να γίνεται ο έλεγχος αποδεκτών τιμών για κορώνα ή γράμματα).

Πριν την ρίψη του κέρματος, ο χρήστης θα απαντά με «ΝΑΙ» ή «ΟΧΙ» αν προτίθεται να το ρίξει το κέρμα (να γίνεται επίσης ο έλεγχος δεδομένων εισόδου)

Β) θα υπολογίζει και θα εμφανίζει ποιος είναι ο νικητής (ποια από τις δύο όψεις είχε τις περισσότερες εμφανίσεις).

Γ) θα υπολογίζει και θα εμφανίζει το μέγιστο πλήθος των διαδοχικών στοιχείων του πίνακα που έχουν την τιμή ‘’Κ’’ (κορώνα).

 

Γ, Κ, Κ, Γ, Κ, Κ, Κ, Κ, Γ, Γ, Κ …

Dim lights

Βελτίωση (διόρθωση) του ερωτήματος Γ

Στην ειδική περίπτωση όπου η ακολουθία Κ, Κ, Κ, Κ του παραδείγματος βρίσκεται στο τέλος των δεδομένων, ο παραπάνω προτεινόμενος κώδικας δε λειτουργεί σωστά (το k θα έχει γίνει 4, αλλά δε θα ""αναμετρηθεί" με το προηγούμενο, μικρότερο του 4, max που είχαμε υπολογίσει).

Πρέπει λοιπόν να συμπληρώσουμε τον ("προληπτικό" για την ακραία προαναφερθείσα περίπτωση) έλεγχο :

 

Αν k > max τότε

max <-- k

Τέλος_αν

 

ανάμεσα στις εντολές :

 

Τέλος_επανάληψης

Εμφάνισε max

sideBar



You are here: Mathman