Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M28-03

Δίνεται παρακάτω ένα πρόγραμμα με ένα υποπρόγραμμα:

 

ΠΡΟΓΡΑΜΜΑ Υπολογισμοί

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ

ΑΡΧΗ

∆ΙΑΒΑΣΕ α, β

γ <-- α + Πράξη (α, β)

ΓΡΑΨΕ γ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

ΣΥΝΑΡΤΗΣΗ Πράξη (χ, ψ): ΠΡΑΓΜΑΤΙΚΗ

ΜΕΤΑΒΛΗΤΕΣ

ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ

ΑΡΧΗ

ΑΝ χ >= ψ ΤΟΤΕ

Πράξη <-- χ – ψ

ΑΛΛΙΩΣ

Πράξη <-- χ + ψ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης.

β. Να ξαναγράψετε το πρόγραμμα που δόθηκε αρχικά, ώστε να επιτελεί την ίδια λειτουργία χωρίς τη χρήση υποπρογράμματος.

γ. Να γράψετε στο τετράδιό σας τις τιμές που θα εμφανιστούν κατά την εκτέλεση του αρχικού προγράμματος που δόθηκε, αν ως τιμές εισόδου δοθούν οι αριθμοί:

i. α = 10 β = 5

ii. α = 5 β = 5

iii. α = 3 β = 5

(ΠΑΝΕΛΛΑΔΙΚΕΣ 2007)

 

Χωρίς ήχο

ερώτημα α

Dim lights

 

ερώτημα β

Dim lights

 

ερώτημα γ

Dim lights

sideBar



You are here: MAIN PAGE