Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M24-07

Δίνεται το παρακάτω τμήμα προγράμματος και μια συνάρτηση:

Διάβασε Κ

L <-- 2

A <-- 1

Όσο A < 8 επανάλαβε

Αν K MOD L = 0 τότε

X <-- Fun(A, L)

αλλιώς

X <-- A + L

Τέλος_αν

Εμφάνισε L, A, X

A <-- A + 2

L <-- L + 1

Τέλος_επανάληψης

……………………

Συνάρτηση Fun(B, Δ) : Ακέραια

Μεταβλητές

Ακέραιες: Β, Δ

Αρχή

Fun <-- (Β + Δ) DIV 2

Τέλος_συνάρτησης

 

Να γράψετε στο τετράδιο σας τις τιμές των μεταβλητών L, A, X, όπως αυτές εκτυπώνονται σε κάθε επανάληψη, όταν για είσοδο δώσουμε την τιμή 10.

(Πανελλήνιες Εξετάσεις 2005)

 

Χωρίς ήχο

Dim lights

 

sideBar



You are here: MAIN PAGE