Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M15-11

Ένας τετραψήφιος αριθμός ΡΙΝ είναι αποθηκευμένος σε ένα κινητό τηλέφωνο.

Ο χρήστης έχει το πολύ 3 προσπάθειες  για να εισάγει το σωστό ΡΙΝ και να ξεκινήσει η λειτουργία του τηλεφώνου.

Μετά από 3 αποτυχημένες προσπάθειες το τηλέφωνο κλειδώνει.

Να γραφεί αλγόριθμος που θα:

α) διαβάζει τους υποψήφιους κωδικούς Κ που εισάγει ο χρήστης,

β) εμφανίζει το μήνυμα “Καλώς ήρθατε” όταν κάποιος κωδικός Κ ταυτιστεί με το ΡΙΝ ή το μήνυμα “Κλείδωσε” σε περίπτωση αποτυχίας.

 

Λύση με εμφωλευμένες δομές επιλογής, χωρίς δομή επανάληψης.

 

Αλγόριθμος Άσκηση

ΡΙΝ <-- 1440    !  Δεδομένα //  PIN  //

Διάβασε Κ

Αν Κ = ΡΙΝ τότε

Εμφάνισε "Καλώς Ήρθατε"

αλλιώς

Διάβασε Κ

Αν Κ = ΡΙΝ τότε

Εμφάνισε "Καλώς Ήρθατε"

αλλιώς

Διάβασε Κ

Αν Κ = ΡΙΝ τότε

Εμφάνισε "Καλώς Ήρθατε"

αλλιώς

Εμφάνισε "Κλείδωσε"

Τέλος_αν

Τέλος_αν

Τέλος_αν

Τέλος Άσκηση

sideBar



You are here: MAIN PAGE