Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M15-04

Δίνεται το παρακάτω τμήμα αλγορίθμου:

 

Χ <-- 0

Α <-- 10

Β <-- 14

ΟΣΟ Β > 0 ΕΠΑΝΑΛΑΒΕ

ΑΝ Β MOD 2 = 0 ΤΟΤΕ

Χ <-- Χ + Α

ΤΕΛΟΣ_ΑΝ

Α <-- Α*2

B <-- B DIV 2

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 

α. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Α και Β στο τέλος κάθε επανάληψης κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου.

β. Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.

(ΕΠΑΝ ΕΣΠ 2008)

α.

Dim lights

β.

Dim lights

sideBar



You are here: MAIN PAGE