Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M10-16

Υπολογισμός Μέσου Όρου (γνωστό πλήθος επαναλήψεων)

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει 5 αριθμούς, θα υπολογίζει και θα εμφανίζει το μέσο όρο τους.

Dim lights

 

Εργαστηριακή Άσκηση

Αντιγράψτε και επικολλήστε το πρόγραμμα στον συντάκτη του προγραμματιστικού περιβάλλοντος.

Στη συνέχεια επιλέξτε Εκτέλεση ή Βηματική Εκτέλεση.

 

ΠΡΟΓΡΑΜΜΑ  Μέσος
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: s, i, x
ΠΡΑΓΜΑΤΙΚΕΣ: MO
ΑΡΧΗ
s <-- 0
i <-- 1
ΟΣΟ i <= 5 ΕΠΑΝΑΛΑΒΕ
ΓΡΑΨΕ 'Δώσε έναν αριθμό : '
ΔΙΑΒΑΣΕ x
s <-- s + x
i <-- i + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO <-- s/5
ΓΡΑΨΕ MO
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
ΠΡΟΓΡΑΜΜΑ  Μέσος
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: s, i, x
ΠΡΑΓΜΑΤΙΚΕΣ: MO
ΑΡΧΗ
 
 
s <-- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
ΓΡΑΨΕ 'Δώσε έναν αριθμό : '
ΔΙΑΒΑΣΕ x
s <-- s + x
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
MO <-- s/5
ΓΡΑΨΕ 'Μέσος όρος : ', MO
 
 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

Κάνετε αντιγραφή κι επικόλληση του κώδικα στον online compiler της Python

https://www.tutorialspoint.com/execute_python_online.php

 

# Python

sum = 0

i = 1

while i <= 5:

    x = int(input("Enter x: "))

    sum = sum + x

    i = i+1    

ave=sum/5

print('The average is', ave)

 

 

sideBar



You are here: MAIN PAGE