Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-M10-17

Καταμέτρηση και Ποσοστό μιας ιδιότητας:

Να γραφεί αλγόριθμος ο οποίος θα διαβάζει 8 ακέραιους αριθμούς και θα εμφανίζει το πλήθος των θετικών μη μηδενικών και το ποσοστό τους επί του συνόλου.

Dim lights

 

Εργαστηριακή Άσκηση

Αντιγράψτε και επικολλήστε το πρόγραμμα στον συντάκτη του προγραμματιστικού περιβάλλοντος.

Στη συνέχεια επιλέξτε Εκτέλεση ή Βηματική Εκτέλεση.

 

ΠΡΟΓΡΑΜΜΑ  Μέσος

ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ: k, i, x
ΠΡΑΓΜΑΤΙΚΕΣ: ποσ
ΑΡΧΗ
k <-- 0
ΓΙΑ ΑΠΟ 1 ΜΕΧΡΙ 8
ΓΡΑΨΕ 'Δώσε έναν αριθμό : '
ΔΙΑΒΑΣΕ x
ΑΝ x > 0 ΤΟΤΕ
k <-- k + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ποσ <-- k*100/8
ΓΡΑΨΕ 'Πλήθος : ', k
ΓΡΑΨΕ 'Ποσοστό : ', ποσ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

sideBar



You are here: Mathman