Mathman.gr

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

AE-EK152

Δίνεται το παρακάτω τμήμα αλγορίθμου:

ΜΑΧ ← Α[1]

ΜΙΝ ← Α[1]

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5

ΑΝ Α[i] < ΜΙΝ ΤΟΤΕ

ΜΙΝ ← Α[i]

ΑΛΛΙΩΣ

ΑΝ Α[i] > MAX TOTE

ΜΑΧ ← Α[i]

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΕΜΦΑΝΙΣΕ ΜΙΝ, ΜΑΧ

Να μετατρέψετε το παραπάνω τμήμα αλγορίθμου σε ισοδύναμο με χρήση της δομής επανάληψης ΟΣΟ ... ΕΠΑΝΑΛΑΒΕ.

(ΕΣΠ 2008)

Dim lights

sideBar



You are here: Mathman